WordPress PHP açık kaynaklı programlama dili kullanılarak geliştirilmiştir . Bu makaleyi yazarken, WordPress en az PHP 5.6.20 veya daha yeni bir sürüm gerektirir. PHP için mevcut kararlı sürüm 7.3.8.

Çoğu paylaşılan barındırma hizmeti sağlayıcısı şu anda kendi sunucularında kurulu PHP 7.0 sürümünü sunmaktadır.

Bazı web barındıranları PHP sürümünüzü kontrol panelinden değiştirmenize bile izin verebilir. Kanama kenarını ve PHP’nin en yeni kararlı sürümlerini web ana bilgisayarları tarafından kullanmamak için çeşitli nedenler vardır, ancak en yaygın neden, en son sürümlerin bazen bazı PHP uygulamalarını kırabilmesidir.

Ancak, onlar da geride kalmak istemiyorlar. Şu anda PHP 5.6. + Gerekli asgari sürümdür ve php 7.0+ genellikle önerilir.

WordPress güncellemelerinde site sağlığı için php sürümünüzün güncellenmesi ile ilgili yukarı fotoğraftaki gibi bir uyarı aldığınız zaman yapmanız gereken işlemler çok basittir.

Öncellikle web sitenizi barındırdığınız hosting panelinize giriş yapınız ve cpanel’i açınız.

Cpanel de Yazılım Bloğunun altında Selcet Php Versiyon bölümü var o bölüme giriş yapınız.

Sisteminizde kullanılan php sürümü orada görüntülenmektedir.

Sürekli güncellenen yazılım dünyasında en güncel cms sistemlerinden wordpress te daha sağlıklı çalışabilmek için PHP 7 sürümünü istemektedir. Sizde bu aşamalar ile sürümü yükseltebilirsiniz.

Gelen ekranda PHP sürümünüzü yükseltiniz ve kaydediniz. 2-3 dk sonra sisteminiz güncellenmiş olacaktır.

WordPress te aldığınız güncelleme uyarısı anında kalkacaktır.

Bu kılavuzun, web sunucunuz tarafından yapılan PHP güncellemelerinin WordPress sitenizi nasıl etkilediğini anlamanıza yardımcı olacağını umarız. Geri bildirim ve sorularınız için lütfen aşağıya bir yorum bırakın.